Resolved
This issue has been resolved. We are no longer observing any impact and Investec is operating normally.
Monitoring
We are seeing improvement across Investec and are continuing to monitor to ensure stability.
Identified
Investec is currently experiencing elevated transaction failure rates affecting cards issued by Investec.
We are actively monitoring transaction performance and will provide updates as soon as stability is restored.