We continue to see Mastercard 3D Secure authentications processing as expected, with stable transaction processing since the 10:39.
Based on the sustained recovery and stable transaction processing observed, we consider the issue resolved. While we are still awaiting final confirmation from Mastercard that the issue has been formally closed on their side, we are no longer observing any impact.
We will continue to monitor closely and will provide further updates should anything change.
Resolved
We continue to see Mastercard 3D Secure authentications processing as expected, with stable transaction processing since the 10:39.
Based on the sustained recovery and stable transaction processing observed, we consider the issue resolved. While we are still awaiting final confirmation from Mastercard that the issue has been formally closed on their side, we are no longer observing any impact.
We will continue to monitor closely and will provide further updates should anything change.
Resolved
We have observed a significant recovery in 3D Secure authentications for Mastercard transactions since 10:39.
We are awaiting confirmation from Mastercard that the issue has been fully resolved.
We will continue to monitor closely to ensure stability and will provide further updates if anything changes.
Monitoring
Mastercard has confirmed that is a global outage on their 3DS platform. As of 10:10, we are seeing an improvement across Mastercard 3DS and are continuing to monitor for any degraded performance. This indicates that Mastercard has resolved the Mastercard Directory Server issue.
Stitch's core platform remained stable throughout.
Identified
We are observing elevated 3DS failure rates on Mastercard issued card transactions.
We are actively monitoring the situation and tracking updates from Mastercard. Stitch's core platform remains fully operational, and other services are unaffected.