Resolved
This issue has been resolved. We are no longer observing any impact and African bank is operating normally.
Monitoring
We are seeing improvement across African Bank beneficiary accounts and are continuing to monitor to ensure stability.
Identified
African Bank is experiencing degraded performance. We are observing higher-than-expected failure rates for instant payouts to African Bank beneficiary accounts.
Our team is monitoring the situation and will provide updates as they become available. Stitch's core platform and all other services remain fully operational.