Resolved
This issue has been resolved. We are no longer observing any impact and First National Bank is operating normally.
Monitoring
We are seeing improvement across First National Bank and are continuing to monitor to ensure stability.
Identified
First National Bank is currently experiencing degraded performance. Some Pay By Bank users transacting via First National Bank may experience slow response times or intermittent errors.
Our team is monitoring the situation and will provide updates as they become available. Stitch's core platform and all other services remain fully operational.