Resolved
This issue has been resolved. We are no longer observing any impact and card and wallet services are operating normally.
Identified
We have noted full recovery on Mastercard’s side, and card and wallet services are currently operating normally.
Our team is continuing to monitor the recovery closely to ensure services remain stable and that there are no further disruptions.
We will continue to monitor the situation and provide a final update once the incident has been fully resolved on Mastercards side.
Identified
Recovery has been noted on Mastercard’s side, and payment processing is returning to normal.
We are continuing to monitor the situation closely to ensure services remain stable.
We’ll provide a further update once the incident is fully resolved.
Identified
Mastercard has acknowledged the issue, and their team is currently investigating.
We continue to monitor the situation closely and will provide further updates as more information becomes available.
Identified
We have identified an issue with Mastercard services, resulting in degraded performance for payment processing. Some card and wallet operations may experience slow response times or failures. Our team is monitoring the situation and will provide updates as they become available. Stitch's core platform and all other services remain fully operational.
Identified
We have identified an issue with one of our wallet service providers, resulting in degraded performance. Some wallet operations may experience slow response times or failures.
Our team is monitoring the situation and will provide updates as they become available. Stitch's core platform and all other services remain fully operational.