Stitch

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Instant payouts to Capitec degraded performance
Resolved·Degraded performance

This issue has been resolved. We are no longer observing any impact and payouts to Capitec are operating normally.

Sat, Sep 19, 2026, 12:30 AM
(22 hours ago)
·
Affected components
Sep 18, 2026, 11:07 PM
Sep 19, 2026, 12:30 AM
Instant - Receiving Bank - Capitec
Updates

Resolved

This issue has been resolved. We are no longer observing any impact and payouts to Capitec are operating normally.

Sat, Sep 19, 2026, 12:30 AM

Monitoring

We are seeing improvement across payouts to Capitec and are continuing to monitor to ensure stability.

Sat, Sep 19, 2026, 12:01 AM(29 minutes earlier)

Identified

Capitec is experiencing degraded performance. Capitec is experiencing degraded performance. We are observing higher-than-expected failure rates for instant payouts to Capitec beneficiary accounts.

Our team is monitoring the situation and will provide updates as they become available. Stitch's core platform and all other services remain fully operational.

Fri, Sep 18, 2026, 11:07 PM(53 minutes earlier)