African Bank Issued Cards degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 04:08 SAST
Monitoring
We have noticed a recovery in transactions using African Bank Issued cards and are actively monitoring the issue
Posted Jul 26, 2024 - 02:16 SAST
Investigating
We are currently experiencing higher-than-expected failure rates for transactions using African Bank Issued cards. Our team is actively investigating the issue. We apologise for any inconvenience and appreciate your patience.
Posted Jul 26, 2024 - 01:17 SAST
This incident affected: Payins (Card).