Instant payouts to ABSA degraded performance

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Jun 14, 2025 - 04:09 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2025 - 03:38 SAST

Identified

ABSA is experiencing degraded performance. We are observing higher-than-expected failure rates for instant payouts to ABSA beneficiary accounts.

Our team is keeping up-to-date with all communication from the bank. We are actively monitoring the situation to ensure we can keep you informed as soon as this issue is resolved and performance is optimal.
Posted Jun 14, 2025 - 02:00 SAST
This incident affected: Payouts (Instant - Receiving Bank - ABSA).