Stitch In-Store card payments degraded performance

Incident Report for Stitch

Resolved

The incident has been successfully resolved. We will continue to monitor to ensure sustained stability.
Posted Jul 03, 2025 - 17:26 SAST

Monitoring

We are seeing improvement across services related to Stitch In-Person payments and continuing to monitor.
Posted Jul 03, 2025 - 17:15 SAST

Identified

We are experiencing an issue with Stitch In-Person payments, resulting in a period of degraded performance that is impacting our services. Our team is working hard to resolve this issue and restore the service as quickly as possible.
Posted Jul 03, 2025 - 16:52 SAST
This incident affected: In-Person Payments (Stitch In-Store Card).