Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2025 - 23:00 SAST
Update
Please note that Absa will be undergoing scheduled maintenance from 23:00 until 05:10 SAST. During this time, services linked to Absa are anticipated to experience degraded performance. The estimated window of maintenance will be under 6 hours and 10 minutes.
Stitch’s core platform remains fully operational.
Posted Mar 14, 2025 - 11:32 SAST
Scheduled
Please note that Absa will be undergoing scheduled maintenance from 23:00 until 05:10 SAST. During this time, services linked to Absa are anticipated to experience degraded performance. The estimated window of maintenance will be under 6 hours and 10 minutes.
Stitch’s core platform remains fully operational.
Posted Mar 11, 2025 - 18:51 SAST
This scheduled maintenance affected: Pay By Bank (ABSA) and Card (Card Issuer - ABSA).