Instant payouts to African Bank degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Jul 24, 2024 - 11:16 SAST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2024 - 09:13 SAST
Investigating
African Bank is experiencing degraded performance where we are observing higher-than-expected failure rates for instant payouts to African Bank beneficiary accounts.

Our team is keeping up-to-date with all communication from the bank. We are actively monitoring the situation to ensure we can update our clients as soon as this issue is resolved and performance is optimal.
Posted Jul 22, 2024 - 12:04 SAST
This incident affected: Payouts (Send Money).