Standard Bank degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Jul 14, 2024 - 03:33 SAST
Monitoring
Standard Bank is currently experiencing degraded performance with their platform. Some Pay by Bank users may experience slow response times or intermittent errors.

We are actively monitoring the situation to ensure we can update our clients as soon as this issue is resolved and performance is optimal.
Posted Jul 14, 2024 - 01:45 SAST
This incident affected: Payins (Pay by bank).