Degraded Performance on Pay by Card

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Sep 11, 2023 - 21:54 SAST

Monitoring

Services have been restored and we will continue to monitor for any further degradations in performance.
Posted Sep 11, 2023 - 21:27 SAST

Update

We are currently experiencing degraded performance on one of our downstream provider services. Our team has already escalated with the provider and is currently working to resolve the issue.

Stitch's core platform is fully operational, and our other services are unaffected.
Posted Sep 11, 2023 - 20:10 SAST

Identified

We are currently experiencing degraded performance on one of our downstream provider services. Our team has already escalated with the provider and is currently working to resolve the issue.

Stitch's core platform is fully operational, and our other services are unaffected.
Posted Sep 11, 2023 - 20:10 SAST