African Bank Issued Cards degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 15:18 SAST
Update
We are continuing to investigate this issue.
Posted Jul 25, 2024 - 09:30 SAST
Investigating
We are currently experiencing higher-than-expected failure rates for transactions using abil cards. Our team is actively investigating the issue. We apologize for any inconvenience and appreciate your patience.
Posted Jul 25, 2024 - 00:42 SAST
This incident affected: Payins (Card).