FNB undergoing maintenance

Incident Report for Stitch

Resolved

We are seeing a full recovery following the FNB maintenance.
No further degraded performance has been noted.
Posted Mar 30, 2025 - 08:53 SAST

Monitoring

FNB maintenance has been concluded. We're seeing an improvement across services related to FNB.
We are continuing to monitor for any degraded performance.
Posted Mar 30, 2025 - 08:09 SAST

Identified

FNB is currently undergoing maintenance.

Subsequently, online payments are temporarily degraded for FNB via Stitch services while the maintenance is underway.

Stitch’s core platform remains fully operational.
Posted Mar 30, 2025 - 01:09 SAST
This incident affected: Pay By Bank (First National Bank).