Stitch In Person: Nexus portal degraded performance

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted May 15, 2025 - 15:57 SAST

Monitoring

A workaround has been implemented and SMS and email receipts should now be flowing smoothly again for all customers.

We’ll continue to monitor the situation closely.
Posted May 14, 2025 - 08:51 SAST

Update

We are continuing to work on a fix for this issue.
Posted May 14, 2025 - 08:49 SAST

Identified

SMS and Email functionality on the Nexus portal is currently degraded, affecting the ability to send SMS or email receipts to cardholders.

The issue began at 1:41 AM, with the last successful SMS sent at 1:54 AM.
Posted May 14, 2025 - 07:12 SAST
This incident affected: In-Person Payments (Stitch Nexus Portal).