Absa Bank temporarily unavailable due to maintenance
Incident Report for Stitch
Resolved
This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Apr 20, 2024 - 04:11 SAST
Monitoring
We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Apr 20, 2024 - 04:04 SAST
Identified
Absa Bank is experiencing degraded performance due to maintenance on their system.

Subsequently, online payments are temporarily unavailable for Absa Bank via Stitch services, but Stitch’s core platform is fully operational.
Posted Apr 20, 2024 - 00:18 SAST
This incident affected: 💰Pay (Pay by Bank).