Degraded 3DS Performance on Absa-Issued Cards

Incident Report for Stitch

Resolved

We're seeing an improvement across services - This incident has been resolved.
We'll continue to monitor the logs for any regression.
Posted Apr 11, 2025 - 19:01 SAST

Identified

ABSA is experiencing higher-than-expected failure rates for transactions using ABSA issued cards.

Our team is keeping up-to-date with all communication from the bank. We are actively monitoring the situation to ensure we can provide an update as soon as this issue is resolved and performance is optimal.
Posted Apr 11, 2025 - 18:32 SAST
This incident affected: Card (Card Issuer - ABSA).