Degraded performance on Pay by bank

Incident Report for Stitch

Resolved

This incident has been resolved.
Posted Sep 22, 2023 - 18:00 SAST

Monitoring

We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Sep 22, 2023 - 17:35 SAST

Update

We are continuing to investigate this issue.
Posted Sep 22, 2023 - 16:34 SAST

Investigating

We are currently experiencing degraded performance with Pay by Bank.

Some users may experience slow response times or intermittent errors when making requests.

Our engineering team is actively working to resolve this to bring this service back online for all users as quickly as possible.
Posted Sep 22, 2023 - 16:22 SAST