Investec degraded performance - card payments

Incident Report for Stitch

Resolved

This incident has been resolved.
Posted Nov 25, 2023 - 10:20 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2023 - 10:15 SAST

Investigating

Investec is currently experiencing degraded performance with their platform, specifically for card payments. Some users may experience slow response times or intermittent errors.

Our team is keeping up-to-date with all communication from the bank. We are actively monitoring the situation to ensure we can update our clients as soon as this issue is resolved and performance is optimal.
Posted Nov 24, 2023 - 20:46 SAST