Downtime/Degraded Performance on Capitec

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Sep 19, 2023 - 05:46 SAST

Monitoring

We are seeing a recovery in payments for Capitec. We will continue monitoring.
Posted Sep 19, 2023 - 05:14 SAST

Identified

Capitec is currently experiencing issues with their mobile application, resulting in a period of degraded performance that is impacting CapitecPay. Our team is keeping up-to-date with all communication from the bank to ensure we can update our clients as soon as this issue is resolved and performance is optimal.

Stitch's core platform is fully operational, and our other services are unaffected.
Posted Sep 19, 2023 - 04:19 SAST