Nedbank Scheduled Maintenance

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Mar 26, 2025 - 03:40 SAST

Monitoring

We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Mar 26, 2025 - 03:29 SAST

Identified

Please note that Nedbank is currently undergoing scheduled maintenance. During this time, services linked to Nedbank are anticipated to experience degraded performance.
Stitch’s core platform remains fully operational.
Posted Mar 26, 2025 - 03:12 SAST
This incident affected: Pay By Bank (Nedbank).