Card 3DS degraded performance

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Mar 16, 2025 - 12:37 SAST

Monitoring

We are seeing an improvement across card services and are continuing to monitor for any degraded performance.
Posted Mar 16, 2025 - 12:24 SAST

Identified

We are still experiencing degraded performance on card services due to an issue with one of our downstream card service providers.

We have implemented mitigating measures to reduce the impact, but some users may still experience degraded performance. We will continue to monitor and provide updates as needed.
Posted Mar 16, 2025 - 12:18 SAST

Investigating

We are currently experiencing degraded performance on card services due to an issue with one of our downstream card service providers.

Our team has already contacted the provider for more information on the problem. We are closely monitoring the situation.
Posted Mar 16, 2025 - 11:32 SAST
This incident affected: Card (3DS provider).