FNB undergoing maintenance

Incident Report for Stitch

Resolved

FNB maintenance has been concluded, we are seeing full recovery. We'll continue to monitor the logs for any regression.
Posted Mar 23, 2025 - 08:13 SAST

Monitoring

We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Mar 23, 2025 - 07:32 SAST

Investigating

FNB is currently undergoing maintenance.

Subsequently, online payments are temporarily degraded for FNB via Stitch services while the maintenance is underway.

Stitch’s core platform remains fully operational.
Posted Mar 23, 2025 - 00:23 SAST
This incident affected: Pay By Bank (First National Bank).