Service provider degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Jul 14, 2024 - 19:51 SAST
Monitoring
We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Jul 14, 2024 - 19:30 SAST
Investigating
We are currently experiencing degraded performance in our services due to an issue with one of our downstream service providers, that is affecting Pay by Card.

Our team has already contacted the provider for more information on the problem. We are closely monitoring the situation.
Posted Jul 14, 2024 - 18:42 SAST
This incident affected: Payins (Card).