Nedbank Issued Cards degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Jul 26, 2024 - 03:33 SAST
Monitoring
There has been a recovery in transactions utilising Nedbank Issued Cards and we are closely monitoring the issue.
Posted Jul 26, 2024 - 02:26 SAST
Investigating
We are currently experiencing higher-than-expected failure rates for transactions using Nedbank Issued cards. Our team is actively investigating the issue. We apologise for any inconvenience and appreciate your patience.
Posted Jul 26, 2024 - 02:09 SAST
This incident affected: Card (Card Issuer - Nedbank).