FNB undergoing maintenance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Apr 21, 2024 - 17:07 SAST
Identified
FNB is currently undergoing maintenance.

Subsequently, online payments may be temporarily degraded for FNB via Stitch services while the maintenance is underway.

Stitch’s core platform remains fully operational.
Posted Apr 21, 2024 - 00:21 SAST
This incident affected: 💰Pay (Pay by Bank).