Capitec degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Mar 25, 2024 - 15:12 SAST
Investigating
Capitec is currently experiencing degraded performance with their platform. Some Pay by Bank users may experience slow response times or intermittent errors.

Our team is keeping up-to-date with all communication from the bank. We are actively monitoring the situation to ensure we can update our clients as soon as this issue is resolved and performance is optimal.
Posted Mar 25, 2024 - 13:04 SAST
This incident affected: 💰Pay (Pay by Bank).