Degraded Performance on Investec
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Apr 21, 2024 - 17:07 SAST
Investigating
We are experiencing an issue with Investec payments on the Pay By Bank channel, resulting in a period of degraded performance that is impacting payments. Our team is working hard to resolve this issue and restore the service as quickly as possible.
Posted Apr 19, 2024 - 00:27 SAST
This incident affected: 💰Pay (Pay by Bank).