FNB is down for maintenance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Mar 16, 2023 - 22:39 SAST
Monitoring
FNB is experiencing degraded performance, this is due to maintenance on their system.
Subsequently, online payments are temporarily unavailable for FNB via Stitch services, but Stitch’s core platform is fully operational.
We apologize for any inconvenience this may cause.
Posted Mar 16, 2023 - 19:39 SAST