Nedbank degraded performance

Incident Report for Stitch

Resolved

We have not noted any further issues related to Nedbank. We will continue to monitor the logs for any regression
Posted Sep 27, 2025 - 22:03 SAST

Monitoring

We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Sep 27, 2025 - 20:48 SAST

Identified

Nedbank is currently experiencing degraded performance on their platform.
Some services linked to Nedbank may be impacted, resulting in slow response times or intermittent errors.

Our team is actively monitoring the situation and staying up to date with all communication from the bank. We will provide updates as they become available.

Stitch’s core platform remains fully operational.
Posted Sep 27, 2025 - 20:11 SAST
This incident affected: Pay By Bank (Nedbank).