Downtime/Degraded Performance on Standard Bank

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor for any regression.
Posted Sep 19, 2023 - 19:52 SAST

Monitoring

We are seeing a recovery from the Standard Bank platform, and will continue to monitor.
Posted Sep 19, 2023 - 19:22 SAST

Identified

Standard Bank is experiencing degraded performance.

Subsequently, online payments are temporarily unavailable for Standard Bank via Stitch services, but Stitch’s core platform is fully operational.

We apologize for any inconvenience this may cause.
Posted Sep 19, 2023 - 19:01 SAST