Absa bank degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Jul 20, 2024 - 04:04 SAST
Monitoring
We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Jul 20, 2024 - 03:35 SAST
Identified
Please note that ABSA will be undergoing scheduled maintenance until 05:00 SAST. During this time, services linked to ABSA are anticipated to experience degraded performance.

Stitch's core platform remains fully operational.
Posted Jul 20, 2024 - 02:57 SAST
Investigating
Absa bank is currently experiencing degraded performance with their platform. Some Pay by Bank and Absa issued card transactions may experience slow response times or intermittent errors.

Our team is keeping up-to-date with all communication from the bank. We are actively monitoring the situation to ensure we can update our clients as soon as this issue is resolved and performance is optimal.
Posted Jul 20, 2024 - 00:23 SAST
This incident affected: Payins (Pay by bank).