3DS Card service provider degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Oct 20, 2024 - 03:01 SAST
Monitoring
We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Oct 20, 2024 - 02:30 SAST
Identified
We are currently experiencing degraded performance in our services due to an issue with one of our downstream card service providers.

Our team has already contacted the provider for more information on the problem. We are closely monitoring the situation.
Posted Oct 20, 2024 - 02:03 SAST
This incident affected: Card (Service provider).