Investec bank degraded performance

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted May 14, 2025 - 11:20 SAST

Monitoring

We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted May 14, 2025 - 10:43 SAST

Investigating

We are experiencing an issue with the pay by bank payments on Investec bank, resulting in a period of degraded performance that is impacting our services. Our team is working hard to resolve this issue and restore the service as quickly as possible.
Posted May 14, 2025 - 08:24 SAST
This incident affected: Pay By Bank (Investec).