Nedbank issued cards degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 21:52 SAST
Identified
Nedbank is experiencing higher-than-expected failure rates for transactions using Nedbank issued cards.

Our team is keeping up-to-date with all communication from the bank. We are actively monitoring the situation to ensure we can provide an update as soon as this issue is resolved and performance is optimal.
Posted Oct 10, 2024 - 21:22 SAST
This incident affected: Card (Card Issuer - Nedbank).