Standard Bank degraded performance

Incident Report for Stitch

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 14:24 SAST

Monitoring

We are monitoring the results.
Posted Apr 24, 2025 - 14:20 SAST

Investigating

Standard Bank is experiencing degraded performance. Some Pay by Bank users may experience slow response times or intermittent errors. We are observing higher-than-expected failure rates for instant payouts to Standard Bank beneficiary accounts.

We are actively monitoring the situation to ensure we can update our clients as soon as this issue is resolved and performance is optimal.
Posted Apr 24, 2025 - 14:17 SAST
This incident affected: Payouts (Instant - Receiving Bank - Standard Bank) and Pay By Bank (Standard bank).