Nedbank undergoing maintenance
Incident Report for Stitch
Resolved
We are seeing a full recovery across services and are continuing to monitor for any regression.
Posted Apr 22, 2024 - 02:55 SAST
Monitoring
We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Apr 22, 2024 - 02:18 SAST
Identified
Nedbank is currently undergoing maintenance.

Subsequently, online payments are temporarily degraded for Nedbank via Stitch services while the maintenance is underway.

Stitch’s core platform remains fully operational.
Posted Apr 22, 2024 - 01:58 SAST
This incident affected: 💰Pay (Pay by Bank).