Nedbank Scheduled Maintenance

Incident Report for Stitch

Resolved

Maintenance has concluded. We'll continue to monitor the logs for any regression.
Posted Mar 28, 2025 - 03:01 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 28, 2025 - 02:41 SAST

Identified

Please note that Nedbank is currently undergoing scheduled maintenance. During this time, services linked to Nedbank are anticipated to experience degraded performance.

Stitch’s core platform remains fully operational.
Posted Mar 28, 2025 - 02:26 SAST
This incident affected: Pay By Bank (Nedbank) and Card (Card Issuer - Nedbank).