FNB undergoing maintenance

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Apr 13, 2025 - 23:40 SAST

Monitoring

We're seeing an improvement across services related to FNB and are continuing to monitor for any degraded performance.
Posted Apr 13, 2025 - 22:46 SAST

Identified

FNB is currently undergoing maintenance.

Subsequently, online payments are temporarily degraded for FNB via Stitch services while the maintenance is underway.

Stitch’s core platform remains fully operational.
Posted Apr 13, 2025 - 20:10 SAST
This incident affected: Pay By Bank (First National Bank).