Downstream provider degraded performance
Incident Report for Stitch
Resolved
This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Oct 18, 2024 - 10:52 SAST
Monitoring
We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Oct 18, 2024 - 10:31 SAST
Investigating
We have identified degraded performance in our card services due to an issue with the downstream service provider.

Our team has already contacted the provider for more information on the problem, and we are working on resolving the issue.
Posted Oct 18, 2024 - 10:15 SAST
This incident affected: Card (Service provider).