Slow 3DS loading times

Incident Report for Stitch

Resolved

This has been resolved. We'll continue to monitor for any regression.
Posted Mar 15, 2025 - 05:05 SAST

Update

We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Mar 15, 2025 - 04:30 SAST

Identified

We’re experiencing slower loading times with our 3DS service.

Some card users may experience slow response times or intermittent errors.

Our team is investigating the issue and will provide updates on the progress.
Posted Mar 15, 2025 - 01:47 SAST
This incident affected: Card (3DS provider).