Degraded performance on Mastercard payments
Incident Report for Stitch
Resolved
This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Oct 19, 2024 - 18:30 SAST
Investigating
Mastercard is experiencing degraded performance for 3D secure transactions, we have escalated it to our provider and are working on resolving it.
Posted Oct 19, 2024 - 13:45 SAST
This incident affected: Card (3DS provider).