Stitch API - Degraded Performance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted May 24, 2023 - 07:13 SAST
Update
We are continuing to monitor for any further issues.
Posted May 24, 2023 - 07:13 SAST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2023 - 17:14 SAST
Identified
Standard Bank is experiencing degraded performance. Some users may experience slow response times or intermittent errors when making requests. Our engineering team is actively working to resolve this, and bring this service back online for all users as quickly as possible. Stitch’s core platform is fully operational.
Posted Apr 20, 2023 - 15:39 SAST
This incident affected: 🌍 Stitch API.