Service provider degraded performance
Incident Report for Stitch
Resolved
The intermittent issue affecting RTC payouts has been resolved by BankServe.
Posted Jul 13, 2024 - 13:10 SAST
Monitoring
We are seeing payments process and are currently monitoring.
Posted Jul 13, 2024 - 12:48 SAST
Update
We are continuing to investigate this issue.
Posted Jul 13, 2024 - 11:56 SAST
Investigating
We are currently experiencing degraded performance affecting RTC payouts due to an issue with one of our downstream service providers, BankServe

Our team has already contacted the provider for more information on the problem. We are closely monitoring the situation.
Posted Jul 13, 2024 - 11:40 SAST
This incident affected: Payouts (Send Money).