Downtime/Degraded Performance on FNB

Incident Report for Stitch

Resolved

This incident has been resolved.
Posted Sep 19, 2023 - 20:48 SAST

Identified

FNB is experiencing degraded performance.

Subsequently, online payments are intermittent for FNB Payments, but Stitch’s core platform is fully operational.

We apologise for any inconvenience this may cause.
Posted Sep 19, 2023 - 20:34 SAST