Nedbank temporarily unavailable due to maintenance

Incident Report for Stitch

Resolved

This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Jul 06, 2025 - 05:33 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2025 - 05:05 SAST

Identified

Nedbank is experiencing degraded performance due to maintenance on their system.

Subsequently, online payments are temporarily unavailable for Nedbank via Stitch services, but Stitch’s core platform is fully operational.
Posted Jul 06, 2025 - 04:06 SAST
This incident affected: Pay By Bank (Nedbank).