Standard Bank - Login Temporarily Unavailable
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted May 24, 2023 - 07:13 SAST
Monitoring
Standard Bank is experiencing degraded performance, this is due to their login services being down.
Subsequently, online payments and account linking are temporarily unavailable for Standard Bank via Stitch services, but Stitch’s core platform is fully operational.
Posted May 23, 2023 - 17:47 SAST