Bankserv is temporarily unavailable due to maintenance
Incident Report for Stitch
Resolved
This incident has been resolved.
Posted Apr 21, 2024 - 11:24 SAST
Monitoring
Bankserv is experiencing degraded performance due to maintenance on their system.

Subsequently, online card payments are temporarily unavailable via Stitch services, but Stitch’s core platform is fully operational.
Posted Apr 21, 2024 - 10:30 SAST
This incident affected: 💰Pay (Pay by Card).