FNB undergoing maintenance
Incident Report for Stitch
Resolved
This incident has been resolved. We'll continue to monitor the logs for any regression.
Posted Oct 13, 2024 - 09:01 SAST
Monitoring
We're seeing an improvement across services and are continuing to monitor for any degraded performance.
Posted Oct 13, 2024 - 05:42 SAST
Investigating
FNB is currently undergoing maintenance.

Subsequently, online payments are temporarily degraded for FNB via Stitch services while the maintenance is underway.

Stitch’s core platform remains fully operational.
Posted Oct 12, 2024 - 23:16 SAST
This incident affected: Payouts (Instant - Receiving Bank - FNB) and Pay By Bank (First National Bank).